Мегаобучалка Главная | О нас | Обратная связь  


Настройка статической маршрутизации




 

Основные преимущества статической маршрутизации состоят в легкости отладки и конфигурации в малых сетях, отсутствии дополнительных накладных затрат (из-за отсутствия протоколов маршрутизации), мгновенной готовности (не нужна задержка для конфигурирования и подстройки), низкой нагрузке на процессор маршрутизатора и предсказуемости в каждый момент времени.

Однако, статическая маршрутизация не подходит для больших сложных сетей, потому что такие сети включают избыточные связи, множество протоколов и смешанные топологии. Маршрутизаторы в сложных сетях должны быстро адаптироваться к изменениям топологии и выбирать лучший маршрут из множества вариантов.

Пример для Router_1:

 

Router1(config)#ip route 192.168.4.0 255.255.255.0 192.168.10.2

Router1(config)#ip route 192.168.5.0 255.255.255.0 192.168.10.2

Router1(config)#ip route 192.168.11.0 255.255.255.0 192.168.10.2

 

Router1(config)#ip route 192.168.7.0 255.255.255.0 192.168.9.2

Router1(config)#ip route 192.168.8.0 255.255.255.0 192.168.9.2

Router1(config)#ip route 192.168.12.0 255.255.255.0 192.168.9.2

Router1(config)#ip route 192.168.6.0 255.255.255.0 192.168.10.2

этот маршрут указывать не обязательно.

 

Рассмотрим еще один пример задания статической маршрутизации (рис.10). Тут используются различные способы указания статических маршрутов.



Рис. 10 – Сеть, в которой настраивается статическая маршрутизация.

 

Вариант 1. Настройка статической маршрутизации на маршрутизаторе 1, с добавлением маршрутов в конкретные сети и прописыванием IP-адреса соседа, как next-hop: (такой вариант мы рассматривали в предыдущем примере)

 

Router1(config)#ip route 172.16.30.0 255.255.255.0 172.16.20.2

Router1(config)#ip route 172.16.31.0 255.255.255.0 172.16.20.2

Router1(config)#ip route 172.16.40.0 255.255.255.0 172.16.20.2

Router1(config)#ip route 172.16.50.0 255.255.255.0 172.16.20.2

Router1(config)#exit

 

Вариант 2. Настройка статической маршрутизации на маршрутизаторе 3, с указанием, что соответствующий трафик нужно отправлять через соответствующие интерфейсы:

 

Router3(config)#ip route 172.16.10.0 255.255.255.0 fa0/0

Router3(config)#ip route 172.16.11.0 255.255.255.0 fa0/0

Router3(config)#ip route 172.16.12.0 255.255.255.0 fa0/0

Router3(config)#ip route 172.16.50.0 255.255.255.0 fa1/0

Router3(config)#exit

 

Вариант 3. Настройка статической маршрутизации на маршрутизаторе 4, с добавлением default route, согласно которому, весь неизвестный трафик (место назначения которого отсутствует в таблице маршрутизации) отправлять через соответствующий интерфейс:

 

Router4(config)#ip route 0.0.0.0 0.0.0.0 fa0/0

Router4(config)#exit

 

К каждому коммутатору можно присоединить нужное количество компьютеров. Каждому компьютеру нужно указать IP-адрес, маску и шлюз.

Настройка VLAN

 

В данном примере нужно разместить два VLAN в первом здании, на двух коммутаторах, и необходимо объединить эти VLAN через маршрутизатор Router1 т.е. запрограммировать inter-VLAN

 

Рис.11 - Схема VLAN

 

1). Создаем на коммутаторах базу данных VLAN

 

Коммутатор Switch0

 

Switch0>enable

Switch0#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch0(config)#vlan 13

Switch0(config-vlan)#name vlan13

Switch0(config-vlan)#exit

Switch0(config)#

Switch0(config)#vlan 14

Switch0(config-vlan)#name vlan14

Switch0(config-vlan)#exit

Switch0(config)#

 

Коммутатор Switch6

 

Switch6>enable

Switch6#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch6(config)#vlan 13

Switch6(config-vlan)#name vlan13

Switch6(config-vlan)#exit

Switch6(config)#

Switch6(config)#vlan 14

Switch6(config-vlan)#name vlan14

Switch6(config-vlan)#exit

Switch6(config)#

 

2). Составляем таблицу коммутации VLAN для каждого коммутатора:

Для коммутатора Switch0

Port Link VLAN  
FastEthernet0/1 Up   Trunk
FastEthernet0/2 Up   Trunk
FastEthernet0/3 Up Access
FastEthernet0/4 Up Access
FastEthernet0/5 Up Access

Для коммутатора Switch6

Port Link VLAN  
FastEthernet0/1 Up   Trunk
FastEthernet0/2 Up Access
FastEthernet0/3 Up Access
FastEthernet0/4 Up Access
FastEthernet0/5 Up Access

 

3). Задаем каждому порту его принадлежность определенному VLAN:

Для коммутатора Switch6

 

Switch6(config)#interface FastEthernet0/2

Switch6(config-if)#switchport access vlan 13

 

Switch6(config)#interface FastEthernet0/3

Switch6(config-if)#switchport access vlan 14

 

Switch6(config)#interface FastEthernet0/4

Switch6(config-if)#switchport access vlan 14

 

Switch6(config)#interface FastEthernet0/1

Switch6(config-if)#switchport mode trunk

Switch6(config-if)#exit

 

Для коммутатора Switch0

 

Switch0(config)#interface FastEthernet0/3

Switch0(config-if)#switchport access vlan 14

 

Switch0(config)#interface FastEthernet0/5

Switch0(config-if)#switchport access vlan 13

 

Switch0(config)#interface FastEthernet0/1

Switch0(config-if)#switchport mode trunk

 

Switch0(config)#interface FastEthernet0/2

Switch0(config-if)#switchport mode trunk

 

Switch0(config-if)#exit

В результате сделанных настроек мы должны увидеть связь между компьютерами, принадлежащими одному VLAN, и отсутствие связи между компьютерами, принадлежащими разным VLAN.

 

4). Настроим связь между VLAN через маршрутизатор Router1.

 

Для VLAN-ов, между которыми будет связь через маршрутизатор нужно иметь в виду, что у них будут разные IP-адреса: у всех хостов, входящих в VLAN13 адрес сети 192.168.13.0 и шлюз 192.168.13.1, у всех хостов, входящих в VLAN14 адрес сети 192.168.14.0 и шлюз 192.168.14.1. Поэтому адреса 192.168.13.1 и 192.168.14.1 нужно присвоить порту маршрутизатора Fa1/0, к которому физически подключаются VLAN13 и VLAN14.

 

Настраиваем порт Fa1/0 на маршрутизаторе:

 

Router1>enable

Router1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router1(config)#

Router1(config)#interface FastEthernet1/0

 

Виртуальный порт Fa1/0.2 настраиваем на VLAN13 и задаем ему IP-адрес 192.168.13.1:

Router1(config-subif)#interface FastEthernet1/0.2

Router1(config-subif)#encapsulation dot1Q 13

Router1(config-subif)#ip address 192.168.13.1 255.255.255.0

 

Виртуальный порт Fa1/0.3 настраиваем на VLAN14 и задаем ему IP-адрес 192.168.14.1:

Router1(config-subif)#interface FastEthernet1/0.3

Router1(config-subif)#encapsulation dot1Q 14

Router1(config-subif)#ip address 192.168.14.1 255.255.255.0

Router1(config-subif)#end

 

Виртуальный порт Fa1/0.1 настраиваем на VLAN1, что означает отсутствие VLAN, т.е. через этот порт будут проходить пакеты, не принадлежащие никакому VLAN. Задаем этому порту IP-адрес 192.168.1.1

Router1(config-if)#interface FastEthernet1/0.1

Router1(config-subif)#encapsulation dot1Q 1

Router1(config-subif)#ip address 192.168.1.1 255.255.255.0

 

В результате получается, что на физическом порту Fa1/0 образуются 3 виртуальных порта с адресами 192.168.13.1, 192.168.14.1, которые будут являться шлюзами для узлов, принадлежащих соответственно 13 и 14 VLAN. Адрес 192.168.1.1 будет использоваться для всех узлов, подключенных к этой сети и не входящих ни в один VLAN.

 

5). Чтобы узлы, принадлежащие разным VLAN, могли поддерживать связь с любым узлом корпоративной сети, на маршрутизаторе Router1 нужно добавить эти номера сетей в таблицу RIP (или OSPF), или учесть это в настройках статической маршрутизации.

 

Выход в Интернет

4.5.1. По технологии Frame Relay

 

Рассмотрим схему на рис.12

Рис.12 – Схема соединения маршрутизаторов с помощью технологии Frame Relay

 

Пусть роутер1 - граничный маршрутизатор нашего предприятия, а роутер2 – маршрутизатор провайдера, через которого у нас будет связь с и-нет.

Между роутерами устанавливаем устройство: WAN Emulation, Cloud PT.

В окне конфигурации каждого из параллельных интерфейсов необходимо указать идентификатор соединения и его имя (рис. 13).

Рис.13 – Окно конфигурации параллельного интерфейса

 

Окно конфигурации Frame Relay позволяет настраивать взаимодействие параллельных портов устройства между собой (рис. 14).

Рис.14 – Окно конфигурации Frame Relay

 

Настройка маршрутизатора 0 (router 0):

Router>enable

Router#configure terminal

Router(config)#interface Serial2/0

Router(config-if)#ip address 215.10.1.1 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#encapsulation frame-relay

Router(config-if)#no shutdown

Router(config-if)#end

 

Настройка маршрутизатора 1 (router 1):

Router>enable

Router#configure terminal

Router(config)#interface Serial0/0

Router(config-if)#ip address 215.10.1.2 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#encapsulation frame-relay

Router(config-if)#no shutdown

Router(config-if)#end

Команда «show interfaces serial»показывает информацию об инкапсуляции и статусе протоколов первого и второго уровня, а также о широковещательном DLCI, о всех используемых в последовательном интерфейсе номерах DLCI и о DLCI, используемом для LMI.

Введём команду «show interfaces serial0» на обоих маршрутизаторах. Она покажет, подсоединены ли вы к Frame Relay. Вы должны увидеть фразы ‘Serial2/0 is up, line protocol is up (connected)’ и ‘DTE LMI up’.

Введём команду «show frame-relay map» на обоих маршрутизаторах. Она покажет отображение локального DLCI на удалённый IP адрес 201-215.10.1.1.

Команда «show frame-relay pvc» должна показать статус PVC ‘ACTIVE’ на обоих роутерах.

Включим inverse-arp:

router1(config-if)#frame-relay inverse-arp

Теперь на router1 она покажет отображение локального DLCI на удалённый IP адрес 102-215.10.1.2.

Пропингуйте оба маршрутизатора.

4.5.2. Выход в Интернет по технологии DSL -см. п. 4.2.1.

Поможем в ✍️ написании учебной работы
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой



Читайте также:
Как построить свою речь (словесное оформление): При подготовке публичного выступления перед оратором возникает вопрос, как лучше словесно оформить свою...
Как распознать напряжение: Говоря о мышечном напряжении, мы в первую очередь имеем в виду мускулы, прикрепленные к костям ...
Почему человек чувствует себя несчастным?: Для начала определим, что такое несчастье. Несчастьем мы будем считать психологическое состояние...
Как вы ведете себя при стрессе?: Вы можете самостоятельно управлять стрессом! Каждый из нас имеет право и возможность уменьшить его воздействие на нас...



©2015-2020 megaobuchalka.ru Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав. (1163)

Почему 1285321 студент выбрали МегаОбучалку...

Система поиска информации

Мобильная версия сайта

Удобная навигация

Нет шокирующей рекламы



(0.039 сек.)
Поможем в написании
> Курсовые, контрольные, дипломные и другие работы со скидкой до 25%
3 569 лучших специалисов, готовы оказать помощь 24/7